The only supported ciphers are AES-128-CBC and AES-256-CBC with the correct



今天有一个客户项目进行内测,需要重新更换另一个环境,之前使用控制面板是wdcp,当前客户服务器端用的是宝塔,常规安装后,各种报错。

于是根据报错,各种调整,Tim 遇到的第一个问题,就是因为项目本身用的是Laravel 框架,那么就得安装 composer ,由于宝塔php版本中禁用函数,我们必须先进行删除putenv,proc_open,不然安装就会报错。

安装composer

安装 composer

首先进行全局安装,但是网上的安装地址,操作后提示版本较老,因为用的阿里云服务器,所以通过阿里云进行安装,2020.08.08这天操作安装路径还好用

composer require alibabacloud/client

成功安装

安装composer

安装完成后,在进入项目文件夹,进行安装

运行命令 composer install

再运行命令 composer dump-autoload

也可以查询一下安装版本运行命令 composer -v

安装composer

完成后,运行项目报错:“The only supported ciphers are AES-128-CBC and AES-256-CBC with the correct”

正常我觉得这部分应该没有问题,不过进行了重置

项目目录

php artisan key:generate

APP-KEY重置

并且,我们进行调整了域名,增加https,之前是http

于是正常跳过,并继续进行测试。

  1. 没有评论

  1. 无通告。